driver core, kobjects, debugfs and sysfs · Supported
Maintainers
- M Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- M "Rafael J. Wysocki" <rafael@kernel.org>
- M Danilo Krummrich <dakr@kernel.org>
Paths
- F
Documentation/core-api/kobject.rst - F
Documentation/driver-api/driver-model/ - F
drivers/base/ - F
fs/debugfs/ - F
fs/sysfs/ - F
include/linux/device/ - F
include/linux/debugfs.h - F
include/linux/device.h - F
include/linux/fwnode.h - F
include/linux/kobj* - F
include/linux/ksysfs.h - F
include/linux/property.h - F
include/linux/sysfs.h - F
kernel/ksysfs.c - F
lib/kobj* - F
rust/kernel/debugfs.rs - F
rust/kernel/debugfs/ - F
rust/kernel/device.rs - F
rust/kernel/device/ - F
rust/kernel/device_id.rs - F
rust/kernel/devres.rs - F
rust/kernel/driver.rs - F
rust/kernel/faux.rs - F
rust/kernel/platform.rs - F
rust/kernel/soc.rs - F
samples/rust/rust_debugfs.rs - F
samples/rust/rust_debugfs_scoped.rs - F
samples/rust/rust_driver_platform.rs - F
samples/rust/rust_driver_faux.rs - F
samples/rust/rust_soc.rs
Last 30 days
Recent patches
Most-recent 12 patches in this subsystem on linux-phy, ordered by date desc.
-
STALE80d
[PATCH 10/10] driver core: class: remove class_find_device_by_of_node()
2026-03-23 · Dmitry Torokhov <dmitry.torokhov@gmail.com> -
STALE392d
Re: [PATCH] Remove error prints for devm_add_action_or_reset()
2025-07-01 · Uwe Kleine-König <ukleinek@kernel.org> -
STALE642d
LANDED [PATCH 3/3] drivers: core: fw_devlink: Make the error message a bit more useful
2024-10-24 · Saravana Kannan <hidden> -
STALE777d
[PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string()
2024-06-03 · Andy Shevchenko <andriy.shevchenko@linux.intel.com> -
STALE1440d
[PATCH linux-phy v2 2/4] device property: Add {fwnode/device}_get_tx_p2p_amplitude()
2022-08-17 · Marek Behún <kabel@kernel.org> -
STALE1441d
[PATCH linux-phy 2/4] device property: Add {fwnode/device}_get_tx_p2p_amplitude()
2022-08-17 · Marek Behún <kabel@kernel.org> -
STALE1625d
[PATCH v2 1/2] platform: make platform_get_irq_optional() optional
2022-02-12 · Sergey Shtylyov <hidden> -
STALE1645d
[PATCH] driver core: platform: Rename platform_get_irq_optional() to platform_get_irq_silent()
2022-01-13 · Uwe Kleine-König <hidden> -
STALE1645d
[PATCH 1/2] platform: make platform_get_irq_optional() optional
2022-01-10 · Sergey Shtylyov <hidden> -
STALE1663d
[PATCH 3/8] device property: Helper to match multiple connections
2021-12-28 · Bjorn Andersson <hidden> -
STALE1663d
[PATCH 4/8] device property: Use multi-connection matchers for single case
2021-12-28 · Bjorn Andersson <hidden> -
STALE1926d
[RFC v1 PATCH 1/3] drivers: soc: add support for soc_device_match returning -EPROBE_DEFER
2021-04-19 · Alice Guo (OSS) <hidden>